const regex = /<link>(\w*)<\/link>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<link>(\\w*)<\\\/link>', 'gm')
const str = `This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>`;
const subst = `<a href="tooltip('\1')">\1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);