import Foundation
let pattern = #"<link>(\w*)<\/link>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="tooltip('\1')">\1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)