use strict;
my $str = 'This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>';
my $regex = qr/<link>(\w*)<\/link>/mp;
my $subst = '<a href="tooltip(\'\\1\')">\\1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";