import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<link>(\\w*)<\\/link>";
final String string = "This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>";
final String subst = "<a href=\"tooltip('\\1')\">\\1</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}