// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<link>(\w*)<\/link>").unwrap();
let string = "This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>";
let substitution = "<a href=\"tooltip('\\1')\">\\1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}