#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<link>(\w*)<\/link>"
Local $sString = "This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>"
Local $sSubst = "<a href="tooltip('\1')">\1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)