package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<link>(\w*)<\/link>`)
var str = `This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>`
var substitution = "<a href="tooltip('\1')">\1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}