$re = '/<link>(\w*)<\/link>/m';
$str = 'This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>';
$subst = "<a href=\"tooltip('\1')\">\1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;