re = /<link>(\w*)<\/link>/m
str = 'This is a sample text containing a link <link>testlink</link>. And another link <link>testlink2</link>'
subst = '<a href="tooltip(\'\\1\')">\\1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result