# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\w'-]+)[ \t]+([\w'-]+)/$2.$1/gm;t' <<< "Peter O'Toole hi res.jpg
Daniel Day-Lewis.jpg"