using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\w'-]+)[ \t]+([\w'-]+)";
string substitution = @"$2.$1";
string input = @"Peter O'Toole hi res.jpg
Daniel Day-Lewis.jpg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}