// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\w'-]+)[ \t]+([\w'-]+)").unwrap();
let string = "Peter O'Toole hi res.jpg
Daniel Day-Lewis.jpg";
let substitution = "$2.$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}