const regex = /^([\w'-]+)[ \t]+([\w'-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w\'-]+)[ \\t]+([\\w\'-]+)', 'gm')
const str = `Peter O'Toole hi res.jpg
Daniel Day-Lewis.jpg`;
const subst = `$2.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);