import re
regex = re.compile(r"^([\w'-]+)[ \t]+([\w'-]+)", flags=re.MULTILINE)
test_str = ("Peter O'Toole hi res.jpg\n"
"Daniel Day-Lewis.jpg")
subst = "$2.$1"
result = regex.sub(subst, test_str)
if result:
print(result)