#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([\w'-]+)[ \t]+([\w'-]+)"
Local $sString = "Peter O'Toole hi res.jpg" & @CRLF & _
"Daniel Day-Lewis.jpg"
Local $sSubst = "$2.$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)