import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\w'-]+)[ \\t]+([\\w'-]+)";
final String string = "Peter O'Toole hi res.jpg\n"
+ "Daniel Day-Lewis.jpg";
final String subst = "$2.$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}