use strict;
my $str = 'Peter O\'Toole hi res.jpg
Daniel Day-Lewis.jpg';
my $regex = qr/^([\w'-]+)[ \t]+([\w'-]+)/mp;
my $subst = '$2.$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";