re = /^([\w'-]+)[ \t]+([\w'-]+)/m
str = 'Peter O\'Toole hi res.jpg
Daniel Day-Lewis.jpg'
subst = '$2.$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result