# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/s(\d)/S\1/gm;t' <<< "NCIS.Los.Angeles.s12e13.720p.HEVC.x265-MeGusta[eztv.re]"