import re
regex = re.compile(r"s(\d)", flags=re.MULTILINE)
test_str = "NCIS.Los.Angeles.s12e13.720p.HEVC.x265-MeGusta[eztv.re]"
subst = "S\\1"
result = regex.sub(subst, test_str)
if result:
print(result)