$re = '/s(\d)/m';
$str = 'NCIS.Los.Angeles.s12e13.720p.HEVC.x265-MeGusta[eztv.re]';
$subst = "S\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;