import Foundation
let pattern = #"s(\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"NCIS.Los.Angeles.s12e13.720p.HEVC.x265-MeGusta[eztv.re]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"S\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)