re = /s(\d)/m
str = 'NCIS.Los.Angeles.s12e13.720p.HEVC.x265-MeGusta[eztv.re]'
subst = 'S\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result