const regex = /s(\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('s(\\d)', 'gm')
const str = `NCIS.Los.Angeles.s12e13.720p.HEVC.x265-MeGusta[eztv.re]`;
const subst = `S\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);