# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[PLCNAME\])(\w+):(\w+)\\/(\d+)/$1$2[$3].$4/gm;t' <<< "[PLCNAME]N7:40/2"