re = /(\[PLCNAME\])(\w+):(\w+)\/(\d+)/m
str = '[PLCNAME]N7:40/2'
subst = '$1$2[$3].$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result