package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[PLCNAME\])(\w+):(\w+)\/(\d+)`)
var str = `[PLCNAME]N7:40/2`
var substitution = "$1$2[$3].$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}