#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\[PLCNAME\])(\w+):(\w+)\/(\d+)"
Local $sString = "[PLCNAME]N7:40/2"
Local $sSubst = "$1$2[$3].$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)