import re
regex = re.compile(r"(\[PLCNAME\])(\w+):(\w+)\/(\d+)", flags=re.MULTILINE)
test_str = "[PLCNAME]N7:40/2"
subst = "$1$2[$3].$4"
result = regex.sub(subst, test_str)
if result:
print(result)