import Foundation
let pattern = #"(\[PLCNAME\])(\w+):(\w+)\/(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[PLCNAME]N7:40/2"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2[$3].$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)