using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[PLCNAME\])(\w+):(\w+)\/(\d+)";
string substitution = @"$1$2[$3].$4";
string input = @"[PLCNAME]N7:40/2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}