const regex = /(\[PLCNAME\])(\w+):(\w+)\/(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[PLCNAME\\])(\\w+):(\\w+)\\\/(\\d+)', 'gm')
const str = `[PLCNAME]N7:40/2`;
const subst = `$1$2[$3].$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);