$re = '/(\[PLCNAME\])(\w+):(\w+)\/(\d+)/m';
$str = '[PLCNAME]N7:40/2';
$subst = "$1$2[$3].$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;