use strict;
my $str = '[PLCNAME]N7:40/2';
my $regex = qr/(\[PLCNAME\])(\w+):(\w+)\/(\d+)/mp;
my $subst = '$1$2[$3].$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";