# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[0-9a-zA-Z])\h*([+\-\=])\h*(-?[0-9a-zA-Z])/ $1 $2/g;t' <<< "+5 + 3
+5+3=3
-d+7
-1-a
+3
+4
-1
3+
4-"