import Foundation
let pattern = #"(?<=[0-9a-zA-Z])\h*([+\-\=])\h*(-?[0-9a-zA-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
+5 + 3
+5+3=3
-d+7
-1-a
+3
+4
-1
3+
4-
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)