#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=[0-9a-zA-Z])\h*([+\-\=])\h*(-?[0-9a-zA-Z])"
Local $sString = "+5 + 3" & @CRLF & _
"+5+3=3" & @CRLF & _
"-d+7" & @CRLF & _
"-1-a" & @CRLF & _
"+3" & @CRLF & _
"+4" & @CRLF & _
"-1" & @CRLF & _
"3+" & @CRLF & _
"4-"
Local $sSubst = " $1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)