# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[0-9a-zA-Z])\h*([+\-\=])\h*(-?[0-9a-zA-Z])"
test_str = ("+5 + 3\n"
"+5+3=3\n"
"-d+7\n"
"-1-a\n"
"+3\n"
"+4\n"
"-1\n"
"3+\n"
"4-")
subst = " $1 $2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.