re = /(?<=[0-9a-zA-Z])\h*([+\-\=])\h*(-?[0-9a-zA-Z])/
str = '+5 + 3
+5+3=3
-d+7
-1-a
+3
+4
-1
3+
4-'
subst = ' $1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result