using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[0-9a-zA-Z])\h*([+\-\=])\h*(-?[0-9a-zA-Z])";
string substitution = @" $1 $2";
string input = @"+5 + 3
+5+3=3
-d+7
-1-a
+3
+4
-1
3+
4-";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}