use strict;
my $str = '+5 + 3
+5+3=3
-d+7
-1-a
+3
+4
-1
3+
4-';
my $regex = qr/(?<=[0-9a-zA-Z])\h*([+\-\=])\h*(-?[0-9a-zA-Z])/p;
my $subst = ' $1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";