import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[0-9a-zA-Z])\\h*([+\\-\\=])\\h*(-?[0-9a-zA-Z])";
final String string = "+5 + 3\n"
+ "+5+3=3\n"
+ "-d+7\n"
+ "-1-a\n"
+ "+3\n"
+ "+4\n"
+ "-1\n"
+ "3+\n"
+ "4-";
final String subst = " $1 $2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}