const regex = /(?<=[0-9a-zA-Z])\h*([+\-\=])\h*(-?[0-9a-zA-Z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[0-9a-zA-Z])\\h*([+\\-\\=])\\h*(-?[0-9a-zA-Z])', 'g')
const str = `+5 + 3
+5+3=3
-d+7
-1-a
+3
+4
-1
3+
4-`;
const subst = ` $1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);