# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\D*\d+\D*)\d+/$1hello/gm;t' <<< "This 9 is 8 a 77 6 test"