$re = '/^(\D*\d+\D*)\d+/m';
$str = 'This 9 is 8 a 77 6 test';
$subst = "$1hello";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;