package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\D*\d+\D*)\d+`)
var str = `This 9 is 8 a 77 6 test`
var substitution = "$1hello"
fmt.Println(re.ReplaceAllString(str, substitution))
}