// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\D*\d+\D*)\d+").unwrap();
let string = "This 9 is 8 a 77 6 test";
let substitution = "$1hello";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}