const regex = /^(\D*\d+\D*)\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\D*\\d+\\D*)\\d+', 'gm')
const str = `This 9 is 8 a 77 6 test`;
const subst = `$1hello`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);