using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\D*\d+\D*)\d+";
string substitution = @"$1hello";
string input = @"This 9 is 8 a 77 6 test";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}