import Foundation
let pattern = #"^(\D*\d+\D*)\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"This 9 is 8 a 77 6 test"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1hello"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)